Acura TLX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Okay, so this started happening after I modded the stock exhaust by swapping the mufflers for performance mufflers. The car basically doesn't want to change gears on time (If I want to cruise and not speed) I get put in this weird situation where the car keeps reaching higher RPMs until this weird sound occurs (When the car makes this noise, I'm still in the gear, and I have to give it gas to finally change onto the next gear. This happens most when the car is fully warmed up and usually transitioning from 4th to 5th or 5th to 6th. I've looked up what "rev hangs" are and they usually happen for manual transmissions. I have a feeling what I'm experiencing isn't exactly rev hang but maybe something similar. Hope someone knows what I'm talking about!
 

·
Super Moderator
Joined
·
773 Posts
Look under the vehicle for anything the exhaust mechanics could have left unplugged. Did they disconnect the battery during the install?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Look under the vehicle for anything the exhaust mechanics could have left unplugged. Did they disconnect the battery during the install?
I had them weld on the mufflers. That's about it. Hope this doesn't have anything to do with it but I'll schedule a visit with the dealer sometime next week. Nothing seems missing or broken from when I've seen under the car. The battery wasn't disconnected.
 
1 - 3 of 3 Posts
Top