Acura TLX Forum banner

Key Fob - Reprogram or Reset?

5941 Views 7 Replies 4 Participants Last post by  Trader
I had a low battery warning for the key fob (Fob #1) on my 2015 Acura TLX SH-AWD. So thinking this was easy I got a couple new batteries and replaced it. As soon as I clicked the cover shut, the car alarm starts blaring. Fortunately I had the #2 Fob handy and shut off the alarm. took the fob apart again, put it back together, same thing. So I just set it aside and since I am not driving that much in the Covid world I thought I'd figure it out later (called the dealer, of course they say bring it in, which I'm not going to do at the moment). I looked at the fob, noticed that the car alarm button was sort of crooked in the housing so figured it may have been depressed each time I clicked the fob shut. I took it apart again, put another new battery in (tested to make sure it was charged with a voltmeter). Put it back together, and at least the alarm did not go off, but it does nothing. No clicks, nothing works. I can still use it to start the car by holding next to the start button, but I cannot use the remote to lock/unlock the doors, trunk, etc. Now I think maybe the programming has been lost but I really do not know. Replacing the battery was pretty straightforward and I was careful not to bend the prongs, etc. Plenty of videos out there on replacing the battery, but I'm not sure if I have lost the program and need to re-set. Before I take it to the dealer to charge me $100 to walk in the door, I thought I'd take one shot at the forum and see if anyone has an idea? Thanks for any help.
See less See more
1 - 2 of 8 Posts
Thanks for the feedback, I did all that took the fob back apart, carefully lined up all the button. Still nothing. I'm going to get a couple new batteries again and see what happens. the fob works with the touch to the start button method and then start the car, but still no remote locks, trunk unlock, etc.. It's been so long since I had it working, I forget if it should blink green when it's powered, so even though the batteries check as good, could still be that. I'm tempted to open Fob#2 and use the battery from that one, but not sure if I want to mess with that one, since it's working ! My history with DIY projects is I end up doing more harm than good ! Anyway, thanks for the reply !
Yeah - I'd avoid messing with key Fob #2, at least right now you have one working.
Thanks for the help...Amazingly I brought the key fob in, put it in the drawer and when I went to use it 2 days later it was working like a charm...fixed itself? I read someplace that these fobs have two batteries in them, the replaceable C2032 and another one internal. Seems like the internal one may have been dead and the new replaceable recharged it just sitting in the drawer. Seems crazy, but in any event, it's working fine, all functions work and I did not have to go to the dealer ! yay... now I need to go work on the leaking toilet, but that's another story.
Glad to hear it all worked out!
1 - 2 of 8 Posts